using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z])(?=.*[!@#$%^&+=]).{10,16}$";
string input = @"1a3@56A89
1a3@56A890
1a3@56A8901
1a3@56A89012
1a3@56A890123
1a3@56A8901234
1a3@56A89012345
1a3@56A890123456
1a3@56A8901234567
1a3@56A8901234568
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}