package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\Bn`)
var str = `an answer or a question`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}