import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([a-zA-Z]{2}-?\\d{2}-?\\d{2})|(\\d{2}-?\\d{2}-?[a-zA-Z]{2})|(\\d{2}-?[a-zA-Z]{2}-?\\d{2})|([a-zA-Z]{2}-?\\d{2}-?[a-zA-Z]{2})|([a-zA-Z]{2}-?[a-zA-Z]{2}-?\\d{2})|(\\d{2}-?[a-zA-Z]{2}-?[a-zA-Z]{2})|(\\d{2}-?[a-zA-Z]{3}-?\\d{1})|(\\d{1}-?[a-zA-Z]{3}-?\\d{2})|([a-zA-Z]{2}-?\\d{3}-?[a-zA-Z]{1})|([a-zA-Z]{1}-?\\d{3}-?[a-zA-Z]{2})|([a-zA-Z]{3}-?\\d{2}-?[a-zA-Z]{1})|([a-zA-Z]{1}-?\\d{2}-?[a-zA-Z]{3})|(\\d{1}-?[a-zA-Z]{2}-?\\d{3})|(\\d{3}-?[a-zA-Z]{2}-?\\d{1}))$";
final String string = "xx-99-99\n"
+ "99-99-xx\n"
+ "99-xx-99\n"
+ "xx-99-xx\n"
+ "xx-xx-99\n"
+ "99-xx-xx\n"
+ "99-xxx-9\n"
+ "9-xxx-99\n"
+ "xx-999-x\n"
+ "x-999-xx\n"
+ "xxx-99-x\n"
+ "x-99-xxx\n"
+ "9-xx-999\n"
+ "999-xx-9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}