re = /(?:[+\-*@&\/%^|^]|([*\/><])\1)=/m
str = 'augop: "+=" | "-=" | "*=" | "/=" | "%=" | "**="
| ">>=" | "<<=" | "&=" | "^=" | "|="
foo <<= bar
foo >>= bar
*>='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end