$re = '@^/.*?/.*?/(.*)(_i[0-9]{0,999})@m';
$str = '/ads/sell';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);