using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\w/-]+|_|(?<![\d-])\d+(?!\d*-)";
string substitution = @"";
string input = @"456ml";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}