#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<div.*?price.*?>(\d+\.\d+)<\/div>"
Local $sString = "<section data-v-7630ac7c="" view-more-component="">" & @CRLF & _
"<div data-v-5c5571e4="" table-component="" data-v-7630ac7c="">" & @CRLF & _
"<header data-v-5c5571e4="">" & @CRLF & _
"<div data-v-5c5571e4="" price="" right-align="">Price</div> " & @CRLF & _
"<div data-v-5c5571e4="" quantity="" right-align="">Quantity</div> " & @CRLF & _
"<div data-v-5c5571e4="" date="">Time</div></header> <section data-v-5c5571e4="">" & @CRLF & _
"<div data-v-5c5571e4="" price="" right-align="" style="color: rgb(142, 201, 25);">8611.00</div> " & @CRLF & _
"<div data-v-5c5571e4="" quantity="" right-align="">1.00000000</div> " & @CRLF & _
"<div data-v-5c5571e4="" date="">13:27:17</div></section><section data-v-5c5571e4="">" & @CRLF & _
"<div data-v-5c5571e4="" price="" right-align="" style="color: rgb(142, 201, 25);">8612.30</div> " & @CRLF & _
"<div data-v-5c5571e4="" quantity="" right-align="">1.00000000</div> " & @CRLF & _
"<div data-v-5c5571e4="" date="">13:03:12</div></section><section data-v-5c5571e4="">" & @CRLF & _
"<div data-v-5c5571e4="" price="" right-align="" style="color: rgb(255, 42, 104);">8517.70</div> " & @CRLF & _
"<div data-v-5c5571e4="" quantity="" right-align="">0.04983464</div> " & @CRLF & _
"<div data-v-5c5571e4="" date="">12:51:24</div></section><section data-v-5c5571e4="">" & @CRLF & _
"<div data-v-5c5571e4="" price="" right-align="" style="color: rgb(142, 201, 25);">8608.70</div> " & @CRLF & _
"<div data-v-5c5571e4="" quantity="" right-align="">0.59195657</div> " & @CRLF & _
"<div data-v-5c5571e4="" date="">12:32:26</div></section><section data-v-5c5571e4="">" & @CRLF & _
"<div data-v-5c5571e4="" price="" right-align="" style="color: rgb(255, 42, 104);">8521.70</div> " & @CRLF & _
"<div data-v-5c5571e4="" quantity="" right-align="">0.02990000</div> " & @CRLF & _
"<div data-v-5c5571e4="" date="">11:29:57</div></section><section data-v-5c5571e4="">" & @CRLF & _
"<div data-v-5c5571e4="" price="" right-align="" style="color: rgb(142, 201, 25);">8545.20</div> " & @CRLF & _
"<div data-v-5c5571e4="" quantity="" right-align="">0.26101049</div> " & @CRLF & _
"<div data-v-5c5571e4="" date="">01:20:35</div></section><section data-v-5c5571e4="">" & @CRLF & _
"<div data-v-5c5571e4="" price="" right-align="" style="color: rgb(255, 42, 104);">8462.30</div> " & @CRLF & _
"<div data-v-5c5571e4="" quantity="" right-align="">0.00674370</div> " & @CRLF & _
"<div data-v-5c5571e4="" date="">23:49:47</div></section><section data-v-5c5571e4="">" & @CRLF & _
"<div data-v-5c5571e4="" price="" right-align="" style="color: rgb(142, 201, 25);">8539.30</div> " & @CRLF & _
"<div data-v-5c5571e4="" quantity="" right-align="">0.05799985</div> " & @CRLF & _
"<div data-v-5c5571e4="" date="">23:00:53</div></section><section data-v-5c5571e4="">" & @CRLF & _
"<div data-v-5c5571e4="" price="" right-align="" style="color: rgb(255, 42, 104);">8446.00</div> " & @CRLF & _
"<div data-v-5c5571e4="" quantity="" right-align="">0.02345439</div> " & @CRLF & _
"<div data-v-5c5571e4="" date="">22:30:43</div></section><section data-v-5c5571e4="">" & @CRLF & _
"<div data-v-5c5571e4="" price="" right-align="" style="color: rgb(255, 42, 104);">8540.00</div> " & @CRLF & _
"<div data-v-5c5571e4="" quantity="" right-align="">0.25500001</div> " & @CRLF & _
"<div data-v-5c5571e4="" date="">21:55:28</div></section></div> " & @CRLF & _
"<section data-v-7630ac7c="" id="my-trades"><div data-v-75ce2ffa="" data-v-7630ac7c="" button-component="" class="viewmore fullbutton">" & @CRLF & _
"<button data-v-75ce2ffa=""></button> " & @CRLF & _
"<!----> <span data-v-75ce2ffa="" text="">View More</span> <!----></div> <!----></section> <!----> <!----></section> <!---->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")