import re
regex = re.compile(r"^(\d{1,3}\.?(?:\d{1,3}\.?)*)? ?([^\W\d]+)", flags=re.MULTILINE)
test_str = ("section\n"
"1 section\n"
"2. section\n"
"2.1 subsection\n"
"2.1.1 subsection\n"
"2.1.1. subsection\n\n"
"1111\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")