#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((2[0-4]\d|25[0-5]|[01]?\d{1,2})\.){3}(2[0-4]\d|25[0-5]|[01]?\d{1,2})"
Local $sString = "Computers communicate over the Internet using the IP protocol (Internet Protocol), which uses numerical addresses, called IP addresses, made up of four whole numbers (4 bytes) between 0 and 255 and written in the format xxx.xxx.xxx.xxx. For example, 194.153.205.26 is an IP address given in technical format." & @CRLF & _
"" & @CRLF & _
"These addresses are used by networked computers to communicate, so each computer on a network has a unique IP address on that network." & @CRLF & _
"" & @CRLF & _
"It is ICANN (Internet Corporation for Assigned Names and Numbers, replaced since 1998 by IANA, Internet Assigned Numbers Agency) which is responsible for allocating public IP addresses, i.e. IP addresses for computers directly connected to the public internet network." & @CRLF & _
"" & @CRLF & _
"Decrypting an IP address" & @CRLF & _
"" & @CRLF & _
"An IP address is a 32 bit address, generally written in the format of 4 whole numbers separated by dots. There are two distinct parts to an IP address:" & @CRLF & _
"" & @CRLF & _
"the numbers to the left indicate the network and are called the netID," & @CRLF & _
"the numbers to the right indicate the computers on this network and are called the host-ID." & @CRLF & _
"Shown in the example below:" & @CRLF & _
"" & @CRLF & _
"network example" & @CRLF & _
"" & @CRLF & _
"Note the network to the left 194.28.12.25. It contains the following computers:" & @CRLF & _
"" & @CRLF & _
"194.28.12.1 to 194.28.12.4" & @CRLF & _
"Note that of the right 178.12.0.0. It includes the following computers:" & @CRLF & _
"" & @CRLF & _
"178.12.77.1 to 178.12.77.6" & @CRLF & _
"In the case above, the networks are written 194.28.12 and 178.12.77, then each computer making up the network is numbered incrementally." & @CRLF & _
"" & @CRLF & _
"Take a network written 58.0.0.0. The computers on this network could have IP addresses going from 58.0.0.1 to 58.255.255.254. So, it is a case of allocating the numbers in such a way that there is a structure in the hierarchy of the computers and servers." & @CRLF & _
"" & @CRLF & _
"So, the smaller the number of bits reserved on the network, the more computers it can contain." & @CRLF & _
"" & @CRLF & _
"In fact, a network written 102.0.0.0 can contain computers whose IP address can vary between 102.001.001.255 and 102.255.255.254 (256*256*256-2=16,777,214 possibilities), while a network written 194.24 can only contain computers where the IP address is between 194.26.0.1 and 194.26.255.254 (256*256-2=65,534 possibilities), this is the notion of IP address classes." & @CRLF & _
"" & @CRLF & _
"Special addresses." & @CRLF & _
"" & @CRLF & _
"When the host-id is cancelled, i.e. when the bits reserved for the machines on the network are replaced by zeros (for example 194.28.12.0), something called a network address is obtained. This address cannot be allocated to any of the computers on the network." & @CRLF & _
"" & @CRLF & _
"When the netid is cancelled, i.e. when the bits reserved for the network are replaced by zeros, a machine address is obtained. This address represents the machine specified by the host-ID which is found on the current network." & @CRLF & _
"" & @CRLF & _
"When all the bits of the host-id are at 1, the address obtained is called the broadcast address. This a specific address, enabling a message to be sent to all the machines on the network specified by the netID." & @CRLF & _
"" & @CRLF & _
"Conversely, when all the bits of the netid are at 1, the address obtained is called the multicast address." & @CRLF & _
"" & @CRLF & _
"Finally the address 127.0.0.1 is called the loopback address because it indicates the localhost." & @CRLF & _
"" & @CRLF & _
"Network classes" & @CRLF & _
"" & @CRLF & _
"IP addresses are divided into classes, according to the number of bytes which represent the network." & @CRLF & _
"" & @CRLF & _
"Class A" & @CRLF & _
"" & @CRLF & _
"In a class A IP address, the first byte represents the network." & @CRLF & _
"" & @CRLF & _
"The most significant bit (the first bit, that to the left) is at zero which means that there are 27 (00000000 to 01111111) network possibilities, which is 128 possibilities However, the 0 network (bits valuing 00000000) does not exist and number 127 is reserved to indicate your machine." & @CRLF & _
"" & @CRLF & _
"The networks available in class A are therefore networks going from 1.0.0.0 to 126.0.0.0 (the last bytes are zeros which indicate that this is indeed a network and not computers!)" & @CRLF & _
"" & @CRLF & _
"The three bytes to the left represent the computers on the network, the network can therefore contain a number of computers equal to: " & @CRLF & _
"224-2 = 16,777,214 computers." & @CRLF & _
"" & @CRLF & _
"A class A IP address, in binary looks like:" & @CRLF & _
"" & @CRLF & _
"0 xxxxxxx xxxxxxxx xxxxxxxx xxxxxxxx" & @CRLF & _
"Network Computers" & @CRLF & _
"Class B" & @CRLF & _
"" & @CRLF & _
"In a class B IP address, the first two bytes represent the network." & @CRLF & _
"" & @CRLF & _
"The first two bits are 1 and 0, which means that there are 214 (10 000000 00000000 to 10 111111 11111111) network possibilities, which is 16,384 possible networks. The networks available in class B are therefore networks going from 128.0.0.0 to 191.255.0.0." & @CRLF & _
"" & @CRLF & _
"The two bytes to the left represent the computers on the network. The network can therefore contain a number of computers equal to: " & @CRLF & _
"216-21 = 65,534 computers." & @CRLF & _
"" & @CRLF & _
"A class B IP address, in binary looks like:" & @CRLF & _
"" & @CRLF & _
"10 xxxxxx xxxxxxxx xxxxxxxx xxxxxxxx" & @CRLF & _
"Network Computers" & @CRLF & _
"Class C" & @CRLF & _
"" & @CRLF & _
"In a class C IP address, the first three bytes represent the network. The first three bits are 1,1 and 0 which means that there are 221 network possibilities, i.e. 2,097,152. The networks available in class C are therefore networks going from 192.0.0.0 to 223.255.255.0." & @CRLF & _
"" & @CRLF & _
"The byte to the left represents the computers on the network, the network can therefore contain: " & @CRLF & _
"28-21 = 254 computers." & @CRLF & _
"" & @CRLF & _
"In binary, a class C IP address looks like:" & @CRLF & _
"" & @CRLF & _
"110 xxxxx xxxxxxxx xxxxxxxx xxxxxxxx" & @CRLF & _
"Network Computers" & @CRLF & _
"Allocation of IP addresses" & @CRLF & _
"" & @CRLF & _
"The aim of dividing IP addresses into three classes A, B and C is to make the search for a computer on the network easier. In fact, with this notation it is possible to firstly search for the network that you want to reach, then search for a computer on this network. So, allocation of IP address is done according to the size of the network." & @CRLF & _
"" & @CRLF & _
"Class Number of possible networks Maximum number of computers on each one" & @CRLF & _
"A 126 16777214" & @CRLF & _
"B 16384 65534" & @CRLF & _
"C 2097152 254" & @CRLF & _
"Class A addresses are used for very large networks, while class C addresses are for example allocated to small company networks." & @CRLF & _
"" & @CRLF & _
"Reserved IP addresses" & @CRLF & _
"" & @CRLF & _
"It frequently happens that in a company or organization only one computer is linked to the Internet and it is through this that other computers on the network access the Internet (generally we talk of a proxy or gateway)." & @CRLF & _
"" & @CRLF & _
"In such a case, only the computer linked to the network needs to reserve an IP address with ICANN. However, the other computers still need an IP address to be able to communicate with each other internally." & @CRLF & _
"" & @CRLF & _
"So, ICANN has reserved a handful of addresses in each class to enable an IP address to be allocated to computers on a local network linked to the Internet without the risk of creating IP address conflicts on the network of networks. These are the following addresses:" & @CRLF & _
"" & @CRLF & _
"Private class A IP addresses: 10.0.0.1 to 10.255.255.254, enabling the creation of large private networks comprising of thousands of computers." & @CRLF & _
"Private class B IP addresses: 172.16.0.1 to 172.31.255.254, making it possible to create medium sized private networks." & @CRLF & _
"Private class C IP addresses: 192.168.0.1 to 192.168.0.254, for putting in place small private networks." & @CRLF & _
"Subnet masks" & @CRLF & _
"" & @CRLF & _
"Subnet masks" & @CRLF & _
"" & @CRLF & _
"In short, a mask is produced containing 1s with the location of bits that you want to keep and 0s for those you want to cancel. Once this mask is created, you simply put a logical AND between the value you want to mask and the mask in order to keep the part you wish to cancel separate from the rest." & @CRLF & _
"" & @CRLF & _
"So a netmask is presented in the form of 4 bytes separated by dots (like an IP address), it comprises (in its binary notation) zeros at the level of the bits from the IP address that you wish to cancel (and ones at the level of those you want to keep)." & @CRLF & _
"" & @CRLF & _
"Importance of subnet masks" & @CRLF & _
"" & @CRLF & _
"The primary importance of a subnet mask is to enable the simple identification of the network associated to an IP address." & @CRLF & _
"" & @CRLF & _
"Indeed, the network is determined by a certain number of bytes in the IP address (1 byte for class A addresses, 2 for class B and 3 bytes for class C). However, a network is written by taking the number of bytes which characterise it, then completing it with zeros. For example, the network linked to the address 34.56.123.12 is 34.0.0.0, because it is a class A type IP address." & @CRLF & _
"" & @CRLF & _
"To find out the network address linked to the IP address 34.56.123.12, you simply need to apply a mask where the first byte is only made up of 1s (which is 255 in decimal), then 0s in the following bytes. " & @CRLF & _
"The mask is: 11111111.00000000.00000000.00000000 " & @CRLF & _
"The mask associated with the IP address 34.208.123.12 is therefore 255.0.0.0. " & @CRLF & _
"The binary value of 34.208.123.12 is: 00100010.11010000.01111011.00001100 " & @CRLF & _
"So an AND logic between the IP address and the mask gives the following result:" & @CRLF & _
"" & @CRLF & _
"00100010.11010000.01111011.00001100" & @CRLF & _
" AND" & @CRLF & _
"11111111.00000000.00000000.00000000" & @CRLF & _
" =" & @CRLF & _
"00100010.00000000.00000000.00000000" & @CRLF & _
"Which is 34.0.0.0. It is the network linked to the address 34.208.123.12" & @CRLF & _
"By generalising, it is possible to obtain masks relating to each class of address:" & @CRLF & _
"" & @CRLF & _
"For a Class A address, only the first byte must be retained. The mask has the following format 11111111.00000000.00000000.00000000, i.e. 255.0.0.0 in decimal;" & @CRLF & _
"For a Class B address, the first two bytes must be retained, which gives the following mask 11111111.11111111.00000000.00000000, relating to 255.255.0.0 in decimal;" & @CRLF & _
"For a Class C address, by the same reasoning, the mask will have the following format 11111111.11111111.11111111.00000000, i.e. 255.255.255.0 in decimal;" & @CRLF & _
"Creation of subnets" & @CRLF & _
"" & @CRLF & _
"Let us re-examine the example of the network 34.0.0.0, and assume that we want the first two bits of the second byte to make it possible to indicate the network. " & @CRLF & _
"The mask to be applied will then be:" & @CRLF & _
"" & @CRLF & _
"11111111.11000000.00000000.00000000" & @CRLF & _
"" & @CRLF & _
"That is 255.192.0.0" & @CRLF & _
"If we apply this mask to the address 34.208.123.12 we get:" & @CRLF & _
"" & @CRLF & _
"34.192.0.0" & @CRLF & _
"In reality there are 4 possible scenarios for the result of the masking of an IP address of a computer on the network 34.0.0.0" & @CRLF & _
"" & @CRLF & _
"When the first two bits of the second byte are 00, in which case the result of the masking is 34.0.0.0" & @CRLF & _
"When the first two bits of the second byte are 01, in which case the result of the masking is 34.64.0.0" & @CRLF & _
"When the first two bits of the second byte are 10, in which case the result of the masking is 34.128.0.0" & @CRLF & _
"When the first two bits of the second byte are 11, in which case the result of the masking is 34.192.0.0" & @CRLF & _
"Therefore, this masking divides a class A network (able to allow 16,777,214 computers) into 4 subnets - from where the name of subnet mask - can allow 222 computers or 4,194,304 computers." & @CRLF & _
"" & @CRLF & _
"It may be interesting to note that in these two cases, the total number of computers is the same, which is 16,777,214 computers (4 x 4,194,304 - 2 = 16,777,214)." & @CRLF & _
"" & @CRLF & _
"The number of subnets depends on the number of additional bits allocated to the network (here 2). The number of subnets is therefore:" & @CRLF & _
"" & @CRLF & _
"Number of bits Number of subnets" & @CRLF & _
"1 2" & @CRLF & _
"2 4" & @CRLF & _
"3 8" & @CRLF & _
"4 16" & @CRLF & _
"5 32" & @CRLF & _
"6 64" & @CRLF & _
"7 128" & @CRLF & _
"8 (impossible for class C) 256" & @CRLF & _
"" & @CRLF & _
"Related :" & @CRLF & _
"Class a ip address example" & @CRLF & _
"Examples of an ip address." & @CRLF & _
".xxx xxxx" & @CRLF & _
"How To Check Your Android IP Address" & @CRLF & _
"Command Prompt to Find IP Address" & @CRLF & _
"Hide My IP" & @CRLF & _
"What is D-link default Ip Address [Solved] (Solved)" & @CRLF & _
"Finding computer name using IP [Solved] (Solved)" & @CRLF & _
"" & @CRLF & _
" Download this article for free (PDF)" & @CRLF & _
" Previous 1 2 3 4 5 6 7 8 9 10 Next " & @CRLF & _
"" & @CRLF & _
"Sponsored Links You May Like" & @CRLF & _
"1 Simple Trick For All-Day Energy" & @CRLF & _
"Vital Reds Supplement" & @CRLF & _
"Samples That Are Free (As In Free)" & @CRLF & _
"Get it Free" & @CRLF & _
"Reston, Virginia Residents Are Stunned By This New Rule" & @CRLF & _
"Provide-Savings Insurance Quotes" & @CRLF & _
"The Most Addictive Game Of The Year!" & @CRLF & _
"Forge Of Empires - Free Online Game" & @CRLF & _
"What Angie Harmon Looks Like Now is Insane" & @CRLF & _
"Your Daily Dish" & @CRLF & _
"What Mallory From "Family Ties" Looks Like Now Is Insane" & @CRLF & _
"Trend Chaser" & @CRLF & _
" by Taboola " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"Dirección IPDirección IP " & @CRLF & _
"IP AdressenIP Adressen " & @CRLF & _
"Adresse IPAdresse IP " & @CRLF & _
"Indirizzo IPIndirizzo IP " & @CRLF & _
"Endereço IPEndereço IP" & @CRLF & _
"This document entitled « IP Address » from CCM (ccm.net) is made available under the Creative Commons license. You can copy, modify copies of this page, under the conditions stipulated by the license, as this note appears clearly." & @CRLF & _
"PREVIOUS" & @CRLF & _
"Protocol" & @CRLF & _
"NEXT" & @CRLF & _
"DNS (Domain name)" & @CRLF & _
"Sponsored Links You May Like" & @CRLF & _
"Her Dress Dropped Jaws At The 2015 Met Gala" & @CRLF & _
"StyleBistro" & @CRLF & _
"This game will keep you up all night!" & @CRLF & _
"Pirates: Free Online Game" & @CRLF & _
"How Car Dealers Get Rid of Unsold Inventory" & @CRLF & _
"Car.Show" & @CRLF & _
"This Wedding Photographer Caught It All" & @CRLF & _
"Trend Chaser" & @CRLF & _
" by Taboola " & @CRLF & _
"Subscribe to our newsletter" & @CRLF & _
"" & @CRLF & _
"Your email address" & @CRLF & _
" " & @CRLF & _
"Subscribe Team Terms of Use Contact Policies" & @CRLF & _
"health.ccm.net" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")