re = /(\(\(api\) \{)([\s\S]*)(\}\)\)\(\)\;)/
str = '((api) {
someFunctionCall();
}))();
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end