$re = '/([0-9]{2}([-|.|/])[A-Z][a-z]{2}\2[0-9]{4})/m';
$str = '13/Jul/1928, 10-Nov-1934, , 01/Jan-1951,f 25.Dec.1937 23/09/1973, 1/Feb/2016';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);