$re = '/^(([^:]*)\S\s*:\s*\d+\.\d{2}(?!\d))*$/';
$str = '1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.34
1234:432.3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);