re = /^(?:(?!not).)+(?=good)/m
str = 'text is good
text is not good
not text is good'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end