package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+),\s(\w+)\s*(\w*\.?)$`)
var str = `Bob, Dylan Tina
Bob, Dylan T.
Bob, Dylan`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}