re = /(?<CCT>(?:(?<=[A-Z])(?=[^A-Z]))|(?:(?<=[a-z])(?=[^a-z]))|(?:(?<=\d)(?=\D))|(?:(?<=[^A-Za-z\d])(?=[A-Za-z\d])))/
str = 'this regex matches all transitions. 1nur15itmightb3interest1ng'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end