import re
regex = re.compile(r"[^\s@]+@(?:[^][\s@]+|\[[^][]*])", flags=re.MULTILINE)
test_str = ("k1@v1 k2@[v1 v2 v3] k3@v1\n"
"k@")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")