$re = '/\d+([+\-\/*.])\d{0}/m';
$str = '55-
55-5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);