// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*?:\d\d.*?\n+|^\n+$|^.*?replies.*?\n+|^.*?\d\n+|^.*?:\n+|^Last reply.*?\n+").unwrap();
let string = "I recommend XMind 8 and not the newer XMind Zen (I have not tried XMind 2021). It is available here: xmind.net/download/xmind8 (edited)
:heavy_plus_sign:
1
5 replies
Last reply 24 hours agoView thread
Paul Holland 1:49 AM
If you need to convert to a PDF - you do not need to pay for the Pro version. On a Mac just print to a PDF. On a Windows machine use an app that lets you print to a PDF.
:point_up_2:
1
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}