import Foundation
let pattern = #"\d*[a-zA-Z_]+\d*[a-zA-Z_]*\d*[a-zA-Z_]*\d*[a-zA-Z_]*\d*[a-zA-Z_]*\d*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
#078 #Aptannua23 #12adasd #wefwdf asdasd #234sdf23sef23we #we345ewer435
#234se234wer #234wer234wer234wer234wer234wer234wer234wer234wer #wew #w #w3423 #243234234234234 #1 # 34234234234
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)