const regex = /\b\d{10}.*?(?=\b\d{10}|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{10}.*?(?=\\b\\d{10}|$)', 'gm')
const str = `8770304350 PRINTER 4610-2CR W/IRON GRAY COVERS (2921) \$750.75 2881057001 PAYMENT DEVICE - VERIFONE MX915 - WALMART CONSIGNE 8770242020 DISPLAY 4820-5GB USB W/ I/O SUPPORT IRON GRAY \$907.27 8770242216 KEYPAD-MSR 3 TRACK IRON GREY \$213.85 2881037020 CONSIGNED- SCANNER DS6878-SR20117WR IMAGER 2D BLUE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}