package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i:^domain\\[a-z0-9]+$)`)
var str = `domain\test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}