$re = '/([0-9]{1,3}\.){3}[0-9]{1,3}/';
$str = '172.16.254.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);