$re = '/(?<!^|[\s+-])(?=[+-])/m';
$str = '-1x^2+3x^3-x^8+1-x
-1x^2 +3x^3-x^8+1-x';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);