re = /(?<=\/parent\/\d*)(.*)(?=\/.*)/m
str = '/parent/123/child/grand-child
/parent/123/child/grand-child/test/test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end