#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+-\d+-\d+T\d+:\d+:\d+\.\d+\+\d+:\d+ stdout F \[\d+mERROR\[\d+m\[\d+mnetwork_costs_rs::classifier::networkffds_classifier\[\d+m\[\d+m:\[\d+m Could not locate region for local node:"
Local $sString = "2024-06-15T12:36:58.798794309+03:30 stdout F [21mERROR[333m[1112mnetwork_costs_rs::classifier::networkffds_classifier[0m[2m:[0m Could not locate region for local node:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")