$re = '/^[^_]+(?=_|$)/m';
$str = 'ksdfXX2344_vvs_gfedfg
ksdfXX2344';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);