re = /(?<=[a-z])[A-Z][a-z]*|[A-Z][a-z]*(?=[A-Z])/m
str = 'AppleOrange
AppleOrangePear
Pomegranate Yellow Banana'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end