package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ro?ar`)
var str = `The lion said roar rooar roooar roooooooar!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}