$re = '/\\\\\"middleName\\\\\":\\\\\"(?<mn>[^\\\\]+)\\\\\",\\\\\"lastName\\\\\":\\\\\"(?<ln>[^\\\\]+)\\\\\"/';
$str = '\\"middleName\\":\\"L\\",\\"lastName\\":\\"CRIB\\"
\\"middleName\\":\\"X\\",\\"lastName\\":\\"Corey\\"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);