import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<link[^>]*href=\"\\S*abcd\\.css\"[\\s\\S]*\\/>";
final String string = "<html data-reactroot=\"\" class=\"gr__localhost\"><head><link rel=\"stylesheet\" href=\"/dist/qwefqwefqwef.css\" /><link rel=\"stylesheet\" href=\"/dist/abcd.css\" /><meta charset=\"utf-8\"><meta name=\"viewport\" content=\"width=device-width,initial-scale=1,maximum-scale=1,minimum-scale=1,user-scalable=no\"><script type=\"text/javascript\" async=\"\" src=\"https://www.google-analytics.com/analytics.js\"></script><script>window.g_useSSR=true;\n"
+ " window.g_initialData = {};</script><script>window.routerBase = \"/\";</script><link rel=\"stylesheet\" href=\"<script src=\" dist=\"\" umi.4c8c3b87.js\"vendors.f848cc19.chunk.css\"=\"\"><link";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}