import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2}),{1,100}|([0-9a-fA-F]{4}\\\\.[0-9a-fA-F]{4}\\\\.[0-9a-fA-F]{4}),{1,100}";
final String string = "10-10-02-03-16-01,10-10-02-03-16-02,10-10-02-03-16-03,10-10-02-03-16-04,10-10-02-03-16-05,10-10-02-03-16-06,10-10-02-03-16-07,10-10-02-03-16-08,10-10-02-03-16-09,10-10-02-03-16-10,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}