using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d\d?(?:\d*|:\d\d?:\d\d?)$";
string input = @"0123456789
0123456789 word
word
01:00:10
1:2:10
1:10
1:2:
1:";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}