package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):.*`)
var str = `root:x:0:0:root:/root:/bin/bash
daemon:x:1:1:daemon:/usr/sbin:/usr/sbin/nologin
bin:x:2:2:bin:/bin:/usr/sbin/nologin
sys:x:3:3:sys:/dev:/usr/sbin/nologin`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}