#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[a-zA-Z0-9+\/=-]{1,76}[\r|\n|\r\n]?)+"
Local $sString = " Login Register " & @CRLF & _
"PHP Classes" & @CRLF & _
"File: test/sample/message.eml" & @CRLF & _
" Search " & @CRLF & _
"Search" & @CRLF & _
" Search All class groups All class groups Latest entries Latest entries Top 10 charts Top 10 charts Blog Blog Forums Forums Shop Shop Help Help " & @CRLF & _
"Recommend this page to a friend!" & @CRLF & _
" Classes of Manuel Lemos > PHP MIME Email Message Parser > test/sample/message.eml > Download " & @CRLF & _
"File: test/sample/message.eml" & @CRLF & _
"Role: Auxiliary data" & @CRLF & _
"Content type: text/plain" & @CRLF & _
"Description: Sample MIME message file used by the example script" & @CRLF & _
"Class: PHP MIME Email Message Parser" & @CRLF & _
"Decode MIME e-mail messages" & @CRLF & _
"Author: By Manuel Lemos" & @CRLF & _
"Last change: " & @CRLF & _
"Date: 14 years ago" & @CRLF & _
"Size: 9,051 bytes" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Contents" & @CRLF & _
"Class file image Download" & @CRLF & _
"Return-Path: <mlemos@acm.org>" & @CRLF & _
"To: Manuel Lemos <mlemos@linux.local>" & @CRLF & _
"Subject: Testing Manuel Lemos' MIME E-mail composing and sending PHP class: HTML message" & @CRLF & _
"From: mlemos <mlemos@acm.org>" & @CRLF & _
"Reply-To: mlemos <mlemos@acm.org>" & @CRLF & _
"Sender: mlemos@acm.org" & @CRLF & _
"X-Mailer: http://www.phpclasses.org/mimemessage $Revision: 1.63 $ (mail)" & @CRLF & _
"MIME-Version: 1.0" & @CRLF & _
"Content-Type: multipart/mixed; boundary="652b8c4dcb00cdcdda1e16af36781caf"" & @CRLF & _
"Message-ID: <20050430192829.0489.mlemos@acm.org>" & @CRLF & _
"Date: Sat, 30 Apr 2005 19:28:29 -0300" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"--652b8c4dcb00cdcdda1e16af36781caf" & @CRLF & _
"Content-Type: multipart/related; boundary="6a82fb459dcaacd40ab3404529e808dc"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"--6a82fb459dcaacd40ab3404529e808dc" & @CRLF & _
"Content-Type: multipart/alternative; boundary="69c1683a3ee16ef7cf16edd700694a2f"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"--69c1683a3ee16ef7cf16edd700694a2f" & @CRLF & _
"Content-Type: text/plain; charset=ISO-8859-1" & @CRLF & _
"Content-Transfer-Encoding: quoted-printable" & @CRLF & _
"" & @CRLF & _
"This is an HTML message. Please use an HTML capable mail program to read" & @CRLF & _
"this message." & @CRLF & _
"" & @CRLF & _
"--69c1683a3ee16ef7cf16edd700694a2f" & @CRLF & _
"Content-Type: text/html; charset=ISO-8859-1" & @CRLF & _
"Content-Transfer-Encoding: quoted-printable" & @CRLF & _
"" & @CRLF & _
"<html>" & @CRLF & _
"<head>" & @CRLF & _
"<title>Testing Manuel Lemos' MIME E-mail composing and sending PHP class: H=" & @CRLF & _
"TML message</title>" & @CRLF & _
"<style type=3D"text/css"><!--" & @CRLF & _
"body { color: black ; font-family: arial, helvetica, sans-serif ; backgroun=" & @CRLF & _
"d-color: #A3C5CC }" & @CRLF & _
"A:link, A:visited, A:active { text-decoration: underline }" & @CRLF & _
"--></style>" & @CRLF & _
"</head>" & @CRLF & _
"<body>" & @CRLF & _
"<table background=3D"cid:4c837ed463ad29c820668e835a270e8a.gif" width=3D"100=" & @CRLF & _
"%">" & @CRLF & _
"<tr>" & @CRLF & _
"<td>" & @CRLF & _
"<center><h1>Testing Manuel Lemos' MIME E-mail composing and sending PHP cla=" & @CRLF & _
"ss: HTML message</h1></center>" & @CRLF & _
"<hr>" & @CRLF & _
"<P>Hello Manuel,<br><br>" & @CRLF & _
"This message is just to let you know that the <a href=3D"http://www.phpclas=" & @CRLF & _
"ses.org/mimemessage">MIME E-mail message composing and sending PHP class</a=" & @CRLF & _
"> is working as expected.<br><br>" & @CRLF & _
"<center><h2>Here is an image embedded in a message as a separate part:</h2>=" & @CRLF & _
"</center>" & @CRLF & _
"<center><img src=3D"cid:ae0357e57f04b8347f7621662cb63855.gif"></center>Than=" & @CRLF & _
"k you,<br>" & @CRLF & _
"mlemos</p>" & @CRLF & _
"</td>" & @CRLF & _
"</tr>" & @CRLF & _
"</table>" & @CRLF & _
"</body>" & @CRLF & _
"</html>" & @CRLF & _
"--69c1683a3ee16ef7cf16edd700694a2f--" & @CRLF & _
"" & @CRLF & _
"--6a82fb459dcaacd40ab3404529e808dc" & @CRLF & _
"Content-Type: image/gif; name="logo.gif"" & @CRLF & _
"Content-Transfer-Encoding: base64" & @CRLF & _
"Content-Disposition: inline; filename="logo.gif"" & @CRLF & _
"Content-ID: <ae0357e57f04b8347f7621662cb63855.gif>" & @CRLF & _
"" & @CRLF & _
"R0lGODlhlgAjAPMJAAAAAAAA/y8vLz8/P19fX19f339/f4+Pj4+Pz7+/v///////////////////" & @CRLF & _
"/////yH5BAEAAAkALAAAAACWACMAQwT+MMlJq7046827/2AoHYChGAChAkBylgKgKClFyEl6xDMg" & @CRLF & _
"qLFBj3C5uXKplVAxIOxkA8BhdFCpDlMK1urMTrZWbAV8tVS5YsxtxmZHBVOSCcW9zaXyNhslVcto" & @CRLF & _
"RBp5NQYxLAYGLi8oSwoJBlE+BiSNj5E/PDQsmy4pAJWQLAKJY5+hXhZ2dDYldFWtNSFPiXssXnZR" & @CRLF & _
"k5+1pjpBiDMJUXG/Jo7DI4eKfMSmxsJ9GAUB1NXW19jZ2tvc3d7f4OHi2AgZN5vom1kk6F7s6u/p" & @CRLF & _
"m3Ab7AOIiCxOyZuBIv8AOeTJIaYQjiR/kKTr5GQNE3pYSjCJ9mUXClRUsLxaZGciC0X+OlpoOuQo" & @CRLF & _
"ZKdNJnIoKfnxRUQh6FLG0iLxIoYnJd0JEKISJyAQDodp3EUDC48oDnUY7HFI3wEDRjzycQJVZCQT" & @CRLF & _
"Ol7NK+G0qgtkAcOKHUu2rNmzYTVqRMt2bB49bHompSchqg6HcGeANSMxr8sEa2y2HexnSEUTuWri" & @CRLF & _
"SSbkYh7BgGVAnhB1b2REibESYaRoBgqIMYx59tFM9AvQffVG49P5NMZkMlHKhJPJb0knmSKZ6kSX" & @CRLF & _
"JtbeF3Am7ocok6c7cM7pU5xcXiJJETUz16qPrzEfaFgZpvzn7h86YV5r/1mxXeAUMVyEIpnVUGpN" & @CRLF & _
"RlG2ka9b3lP3pm2l6u7P+l/YLj3+RlEHbz1C0kRxSITQaAcilVBMEzmkkEQO8oSOBNg9SN+AX6hV" & @CRLF & _
"z1pjgJiAhwCRsY8ZIp6xj1ruqCgeGeKNGEZwLnIwzTg45qjjjjz2GEA5hAUp5JBEFmnkkSCoWEcZ" & @CRLF & _
"X8yohZNK1pFGPQS4hx0qNSLJlk9wCQORYu5QiMd7bUzGVyNlRiOHSlpuKdGEItHQ3HZ18beRRyws" & @CRLF & _
"YSY/waDTiHf/tWlWUBAJiMJ1/Z0XXU7N0FnREpKM4NChCgbyRDq9XYpOplaKopN9NMkDnBbG+UMC" & @CRLF & _
"QwLWIeaiglES6AjGARcPHCWoVAiatcTnGTABZoLPaPG1phccPv366mEvWEFSLnj+2QaonECwcJt/" & @CRLF & _
"e1Zw3lJvVMmftBdVNQS3UngLCA85YHIQOy6JO9N4eZW7KJwtOUZmGwOMWqejwVW6RQzaikRHX3yI" & @CRLF & _
"osKhDAq8wmnKSmdMwNidSOof9ZG2DoV0RfTVmLFtGmNk+CoZna0HQnPHS3AhRbIeDpqmR09E0bsu" & @CRLF & _
"soeaw994z+rwQVInvqLenBftYjLOVphLFHhV9qsnez8AEUbQRgO737AxChjmyANxuEFHSGi7hFCV" & @CRLF & _
"4jxLst2N8sRJYU+SHiAKjlmCgz2IffbLI5aaQR71hnkxq1ZfHSfKata6YDCJDMAQwY7wOgzhjxgj" & @CRLF & _
"VFQnKB5uX4mr9qJ79pann+VcfcSzsSCd2mw5scqRRvlQ6TgcUelYhu75iPE4JejrsJOFQAG01277" & @CRLF & _
"7bjnrvvuvPfu++/ABy887hfc6OPxyCevPDdAVoDA89BHL/301Fdv/fXYZ6/99tx3Pz0FEQAAOw==" & @CRLF & _
"" & @CRLF & _
"--6a82fb459dcaacd40ab3404529e808dc" & @CRLF & _
"Content-Type: image/gif; name="background.gif"" & @CRLF & _
"Content-Transfer-Encoding: base64" & @CRLF & _
"Content-Disposition: inline; filename="background.gif"" & @CRLF & _
"Content-ID: <4c837ed463ad29c820668e835a270e8a.gif>" & @CRLF & _
"" & @CRLF & _
"R0lGODlh+wHCAPMAAKPFzKLEy6HDyqHCyaDByJ/Ax56/xp2+xZ28xJy7w5u6wpq5wZm4wJm3v5i2" & @CRLF & _
"vpe1vSwAAAAA+wHCAEME/hDISau9OOvNu/9gKI5kaZ5oqq5s675wLM90bd94ru987//AoHBILBqP" & @CRLF & _
"yKRyyWw6n9CodEqtWq+gwSHReHgfjobY8X00FIc019tIHAYS7dqcQCDm3vC4fD4QAhUBBFsMZF8O" & @CRLF & _
"hnkLCAYFW11tb1iTlJWWOXJdZZtmC24Eg3hgYntfbXainJ2fgBSZbG5wFAG0E6+RoAZ3CbwJCgya" & @CRLF & _
"p3cMbAyevQcFAgMGCcRmxr1uyszOxQq+wF4MdcPFx7zJApfk5eYhr3SSGemRsu3dc+4iAqELhZwO" & @CRLF & _
"0X6hkHUHCBRoGtUg0RkEAAUeKhhGAcICBQIODIPooIEBzCTmKcjGYSNd/go3VvQo65zJkyhTqlzJ" & @CRLF & _
"sqXLlzBjypxJs6bNmzhz6tzJs6fPn0CDCh1KtKjRo0iTKl3KtKnTp1CXBhhAwECaq1gPNCIwANDU" & @CRLF & _
"qmkMcG311apWULmyZt3alcPXAma1FgAlgCxVq2LbRt3LF0Y7hwWoEjLEDZUmff8AOjMkTB5gwYu3" & @CRLF & _
"JbhIQUDEZw+4+aE1aNc0R2vcDYjoDBgpBoUDj95yzzRqbH7qgW4t5vUnAfVAoj7NwOOf1QloN7Ad" & @CRLF & _
"u1Xf41b+IlCNsa6rR7DWwTPccTnG5sYvCEKwgPGiZI64A9OsK/Q/BM/0YfuFz13VOwsULLhHps+f" & @CRLF & _
"98Hl0zeDRk0X9Qih/vLPWPjFN197aPyB3IJVBLDMdc5t4OB1A0QowYQQ0vIgdilgyGEgG1roYV0j" & @CRLF & _
"GufhhyBSWGF2s2yIYosqWsjgjDTWaOONOOao44489ujjj0AGKeSQRBZp5JFIJqnkkkw26eSTUMJU" & @CRLF & _
"llpYseXVXWGNdSGWZ6EVF5VWukUVXFdtRUCEU+bFYpRslqNcYKHgk1k8hxWWxjCM0VkdnINJRtkE" & @CRLF & _
"lqH3hWZ/CKJYOBBBJxppu/FWh2qzNUrcmQRE6lpvt+UWUKPD9cbIb5bWhmlxbbL5JoUywiMddHRQ" & @CRLF & _
"x591GWqwXXdsfJeoeMO5UZ4/AaaHKXv1xVKgfghuNuyB9fUHHYAA/u2CEIHlGbiffWuWyuSJMmKA" & @CRLF & _
"bXbbbtuhi9kCUOIEJY57oYsraoduuOfGWO2J6Vor77z01mvvvfjmq+++/Pbr778AByzwwAQXbPDB" & @CRLF & _
"CCfcZDobldLRVfLEEgerjQ1EEEemJMiioZEdkggYizSiqMQKl5wCw6qswg+rDTvc6h0Wq9KAJ5tV" & @CRLF & _
"oGpJF9YysXn8lCfNL8HE88xw4EyzTDNDR4MMNUhfk40mhXkDTdHimHzjzRpgDcB0MEeHswf1sCZn" & @CRLF & _
"GfrQDMrIAYZEkEEOJTQRQweBp5FIDTGCEUiHYWwRXHOPMpLdVgcu+OCEF2744YgnrvjijDfu+OOQ" & @CRLF & _
"Ry755JRXbvnl/phnrvnmnHfu+eegZ57RAqSUzptv75E+M+Bb66L6InZwZ7rpr31aLQBhb2pap548" & @CRLF & _
"e7TsIX8dOr/pIIZQQphFHfGqEbtq/J2/DDrZ13Ga0jt8h/XX9TxvfRmmuPVUatb34INCplxakjtm" & @CRLF & _
"XOQ7aP74c+k1fE4MD7fefvxBbLEeLldsyq/4o9ZzHOOHylBFS7f4RJxQMx/8MeB4ggIDA02ziLno" & @CRLF & _
"wlfGoOByKnUAhZQNWfkzwAXzMEExVFB+86NJ/TDVC4SIZRzFs5Ni5OQ/p7XwLOOwQDXSswgFiYuD" & @CRLF & _
"Z4GMP8AjtvGgJk9aYU2davdCeyzRU2LpBwkb2KjvWCU4T/TN/u1S+BKtYUBrXFue8DYQKFoVAzXa" & @CRLF & _
"eJh/XiYPpZEOFhAMTnzkk8aQWQU+c7yHJkIGkGd4SkDhMJ9i5qMAOu4RAWfiYk1yxwvfaYCRA8oh" & @CRLF & _
"JF14x0bGhgSyaZY07JCMRDLyWWnxTOyc1UmweMaSL5zSKf/xQgnk5lA3TCWWVunCRCrylrjMpS53" & @CRLF & _
"ycte+vKXwAymMIdJzGIa85jITKYyl8nMZjrzmdCMpjSnSc1qWvOa2MymvkY3u9IxMReyW92fuLm6" & @CRLF & _
"2Kmum53SIgZyxx7e9C423AyeNnkUw8RsSnqumsfWKKYnCdozen6iHiGsF483gkF7PIND96oUP7KE" & @CRLF & _
"73zteyj8/tK3JfGVqaHkkmhYMDrPJqzwfjRUlij4hzE4ds1pdGSMxgYYjAQZEBRtSeDKSmMMEGYG" & @CRLF & _
"ghjU4+osGEF9ZNCEG3SEB2s6LTSIsKcl3CkKO2qEj24Sh/ucw/NmmCdXQQMbsbSlzZoGMkSSBYh5" & @CRLF & _
"kWIkEhWc3aARiVc0qE+hSCklkvCbUpQgFTWYRCy+la1bZGoQvHgBMPIznyT7QBkNgsY05m+NNSQa" & @CRLF & _
"Lwx6ijvJsZB69IIdB5nHOjKij9twCCAVGJ7HGlKyiMyhXo0wyUtmoLS2LK0ID+XIEWRys5ycyzg+" & @CRLF & _
"yQ9TtjB2lpyLbZ8qy91mVZK+ReWZVCkNVmp1tMhNrnKX/svc5jr3udCNrnSnS93qWve62M2udrfL" & @CRLF & _
"3e5697vgDa94x0ve8pr3vOhNr3rXy972uve98I2vfOdLXxrBS0Uv8lZGUaUh/OKXXRmAV7jMVV+X" & @CRLF & _
"QLK4vD0TaoHLWq1UEsEJFu0FXknLh3iyM5EssEtQlrK98ZN5QbNqyl71pwqEza752MfZEqrhljg1" & @CRLF & _
"pYMKkBh3FuKTXtUX+LupMkwcETNCA40D6QNiA3tfdunXAkdOEX+1Ba68tjiqLbVOnKp60oNAam6J" & @CRLF & _
"fcyUvTYLAnDHOw8Jjx7Js71YTKWzxX1IV76iyayuWTCwDSIgKJxmqLI5zmp6sg5ZNdV7bkPGQWYh" & @CRLF & _
"0EzR/s8+A1THEt6hIrx6IbByRawKHKjfpEfExVREpUEdzKX3dJe5UaQ6UdT0p18VGCfPF2X8S4QD" & @CRLF & _
"QgaamI24hi1TtTxZyuVZ6AzK6gBnIbE66DmhImlzxAYouUq0XQ+oUhG039P+rAZgG7u1erYFyy6W" & @CRLF & _
"Tt85ddkmHak3PWVaWuePAC9F4Mh6dgdjB/A8tCqbscUxWLmumxp8jsa5A5RuY7xbwtHGtT+Phz69" & @CRLF & _
"nGo0WC60DPt9u0AljxWG8kylh9hsRKw1jbiwx24cDsUKSRwYFPdIq2347NoWkSEAKnG++brnGes7" & @CRLF & _
"sYH1QPVqVdDsOZZXUlN2WYO1soCA9JBoScjNQdvs/n3fKXaxYefOH9BDfD+Z5Db78Dv+WuWUd4Bj" & @CRLF & _
"YwPDx1bNiI03BoO7yRi9CzJBBLlQdj5tTbKIOFQqikHjruN6Bovlw5GnXZxjtMXbZ01O2NnhdawL" & @CRLF & _
"ASOFw8BIxpOSuutUYWfmBjW0U1S+gczhqy0Wzuhmd7Ur5RYW/01Tz3dKcpYVl/Isrs2jBSyZJ4H7" & @CRLF & _
"LIq+4VYUL2NZaCMgQiY1LXSjFH09wWexvovGvvawX2q+d8/73vv+98APvvCHT/ziG//4yE++8pfP" & @CRLF & _
"/OY7//nQj770p0/96lv/+tjPvva3z/3ue//74A+/+MdP/vKb//zoT7/6e3Lf/3KryTDKUPvdBQIB" & @CRLF & _
"/q+JwOuPwYEhbFzcYDjDuPN/lARL/FdLRlcZwdUNnTRbGAZt+fcCHCYzGqd0NJZtrsYJFjFGJ2ZQ" & @CRLF & _
"m1A2kcZiD+gXLKNsMMZsTQdiFvg/IJUID7RjldFjhAVkGaM/6lASRfYu8KcuS6aDO4hkOfh7p7Jl" & @CRLF & _
"bBRlVxYSWSZlfVKDXfZltRJmADFmulJmb3BmBJhbb9YZp1RLV9hmwtUWdBZhnYeFCaZ7Rxdv/5Q8" & @CRLF & _
"gKaCvNBrQ0hCZxhjLhgHXEV1PiQIjhBEkDZT6VFSmkFWhbBppMZBljZqVtZpIUGIqCNqevMYlhdf" & @CRLF & _
"qEYKslZ10zZibbgQDkN1IndyTkcLxiFTulZI/muYRsrjbKA4bNYwNR1nPsn2K6J4PKdYbKXYbSM3" & @CRLF & _
"bSQVeWdybWwIa9Rmi0b3FwUEKAcUU+MGTr4AivP2hGSgbqDIbjDobssIb1IlbzSEbslob894gGUY" & @CRLF & _
"jYkxeyf3GABnhAK3jeTDYxE0J5uRcEtjdYUnaoMXHStGGxlnNxs4cYgARRt3Y8UobB5XVhhXjyTR" & @CRLF & _
"e0jnbfoURkGzDh+wcquACmqFUDD3iiw0LZFmczhmWTknkZ9FdK5IDH0GdArWGaB4kUXHewEpbSZH" & @CRLF & _
"kLX2AVA3dVPHamgjNQ8XZG0Ddl2XLF9HOmF3RPmTKGV3IGdXdWl3k2zXiPBVd3nXV3PHOkRpgk5A" & @CRLF & _
"lYlgg2F8Fw3WlnZW9HiCB2Q0Y3ic8k2Kl5V4JQhUiXgWFgqUh1e9h3mcpy2epxdm+XnjQ1EiMHoQ" & @CRLF & _
"pVtogiWuV3urBxGod4Xnw41huJfjKHvtg3t8GYKEWZiGeZiImZiKuZiM2ZiO+ZiQGZmSOZmUWZmW" & @CRLF & _
"eZmYmZmauZmc2ZlCEQEAOw==" & @CRLF & _
"" & @CRLF & _
"--6a82fb459dcaacd40ab3404529e808dc--" & @CRLF & _
"" & @CRLF & _
"--652b8c4dcb00cdcdda1e16af36781caf" & @CRLF & _
"Content-Type: text/plain; name="attachment.txt"" & @CRLF & _
"Content-Transfer-Encoding: base64" & @CRLF & _
"Content-Disposition: attachment; filename="attachment.txt"" & @CRLF & _
"" & @CRLF & _
"VGhpcyBpcyBqdXN0IGEgcGxhaW4gdGV4dCBhdHRhY2htZW50IGZpbGUgbmFtZWQgYXR0YWNobWVu" & @CRLF & _
"dC50eHQgLg==" & @CRLF & _
"" & @CRLF & _
"--652b8c4dcb00cdcdda1e16af36781caf--" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" Advertise on this site Advertise On This Site Site map Site Map Newsletter Newsletter Statistics Statistics Site tips Site Tips Privacy policy Privacy Policy Contact Contact " & @CRLF & _
"Icontem" & @CRLF & _
"Copyright (c) Icontem 1999-2021" & @CRLF & _
"For more information send a message to info at phpclasses dot org."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")