package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(09[0-9]){4}$`)
var str = `093093098097`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}