re = /(\s+\w+\.(\w+(\.\w+)*))|(\=\>)(\w+(\.\w+)*)/m
str = 'x=>x.ab
x=> x.ab
x => x.ab
x =>x.ab
x =>{return x.ab}
x => {return x.ab;}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end