const regex = /^[a-zA-Z0-9ČŠŽĐ'](?:[A-Z0-9 ČŠŽĐ']{0,31}[A-Z0-9ČŠŽĐ'])?$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9ČŠŽĐ\'](?:[A-Z0-9 ČŠŽĐ\']{0,31}[A-Z0-9ČŠŽĐ\'])?$', 'i')
const str = `Hitre Spletne Strani n'123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}