#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[^A-Z]*[A-Z])(?=[^a-z]*[a-z])(?=[^0-9#?!@$%^&*-]*[0-9#?!@$%^&*-])(?!.*[pP]ass|.*[qQ]wer)(?!.*(.).*\1.*\1).{8,}$"
Local $sString = "Examples that should match:" & @CRLF & _
"" & @CRLF & _
"Test1234!" & @CRLF & _
"Te123stE" & @CRLF & _
"" & @CRLF & _
"Examples that should not match:" & @CRLF & _
"" & @CRLF & _
"Teeest123!" & @CRLF & _
"!TESTT1234" & @CRLF & _
"" & @CRLF & _
"Tesete123$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")