re = /^(?=[^A-Z]*[A-Z])(?=[^a-z]*[a-z])(?=[^0-9#?!@$%^&*-]*[0-9#?!@$%^&*-])(?!.*[pP]ass|.*[qQ]wer)(?!.*(.)\1{2}).{8,}$/m
str = 'Examples that should match:
Test1234!
Te123stE
Tesete123$
Examples that should not match:
Teeest123!
!TESTT1234
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end