$re = '/(\w+) \w+ \1/';
$str = 'Mom loves Mom
Dad loves Mom
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);