// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:AND(?:\sNOT)?|OR)\s+(\S+)$").unwrap();
let string = "k:v AND k1:v1 AND NOT k2:v2 OR k3:v3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}