$re = '/#(?:([a-f\d])\1){3}/mi';
$str = '#00FF11
#66aa44
#FF0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);