package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{6}`)
var str = `658987
Warning: The items....`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}