import re
regex = re.compile(r"#Section(\d+)(?:(?!#Section\d).)*\bJack/M,(\d+)\h+(\d+(?:\.\d+)?)\s(\d+)\h+([-+]?\d+(?:\.\d+)?)\b", flags=re.MULTILINE)
test_str = ("#Section250342,Main,First/HS/12345/Jack/M,200010 10.00 200011 -2.00,\n"
"#Section250322,Main,First/HS/12345/Aaron/N,200010 17.00,\n"
"#Section250399,Main,First/HS/12345/Jimmy/N,200010 12.00,\n"
"#Section251234,Main,First/HS/12345/Jack/M,200011 11.00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")