using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\""'`])(?:[\s\S])*?(?:(?<!\\)\1)";
string input = @"`Hel""lo` 2* ""Hel`lo""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}