# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\S+).*\"*(?:GET|POST|HEAD).* (MJ12bot|Baiduspider|AhrefsBot|UptimeRobot).*\""
test_str = ("69.162.111.222 - - [07/Feb/2017:15:54:14 +0200] \"HEAD / HTTP/1.1\" 200 296 \"http://dummydomain.nl/\" \"Mozilla/5.0+(compatible; UptimeRobot/2.0; http://www.uptimerobot.com/)\"\n"
"185.119.111.222 - - [07/Feb/2017:15:55:37 +0200] \"GET /wp-login.php HTTP/1.1\" 200 2860 \"-\" \"Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.103 Safari/537.36\"\n"
"185.119.111.222 - - [07/Feb/2017:15:55:37 +0200] \"POST /wp-login.php HTTP/1.1\" 200 3610 \"http://www.dummydomain.nl/wp-login.php\" \"Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.103 Safari/537.36\"\n"
"149.210.111.222 - - [07/Feb/2017:15:59:13 +0200] \"POST /wp-cron.php?doing_wp_cron=1496930353.4784278869628906250000 HTTP/1.1\" 200 181 \"http://www.dummydomain.nl/wp-cron.php?doing_wp_cron=1496930353.4784278869628906250000\" \"WordPress/4.7.5; http://www.dummydomain.nl\"\n"
"69.162.111.222 - - [07/Feb/2017:15:59:12 +0200] \"HEAD / HTTP/1.1\" 301 229 \"http://dummydomain.nl/\" \"Mozilla/5.0+(compatible; UptimeRobot/2.0; http://www.uptimerobot.com/)\"")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.