const regex = /<\/h1>[\s\S]*?<p>([\s\S]*?)<\/p>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\\/h1>[\\s\\S]*?<p>([\\s\\S]*?)<\\\/p>', 'g')
const str = `<h1>The quick brown fox jumps over the lazy dog</h1>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nam a dolor eu dui luctus vehicula. Nunc eget dui sed orci ornare consectetur. Morbi ut placerat mi, id aliquet ex. Praesent sagittis tortor tristique nisi placerat eleifend. Aenean at sem vitae augue congue rhoncus. Phasellus semper semper velit eget accumsan. Praesent ligula metus, rhoncus quis tellus eget, malesuada ornare est. Nunc aliquet sapien massa, eget tristique turpis viverra a. Vestibulum laoreet metus non velit pharetra, sit amet vulputate risus porta. Suspendisse eget leo porta augue maximus pellentesque. Maecenas sit amet faucibus mi, ut vestibulum dui. Quisque magna enim, eleifend ut feugiat a, vestibulum at mauris. Etiam efficitur vel odio a tempus.</p>
<h2>Sample Text</h2>
<p>Sed ut perspiciatis unde omnis iste natus error sit voluptatem accusantium doloremque laudantium, totam rem aperiam, eaque ipsa quae ab illo inventore veritatis et quasi architecto beatae vitae dicta sunt explicabo. Nemo enim ipsam voluptatem quia voluptas sit aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos qui ratione voluptatem sequi nesciunt. Neque porro quisquam est, qui dolorem ipsum quia dolor sit amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt ut labore et dolore magnam aliquam quaerat voluptatem. Ut enim ad minima veniam, quis nostrum exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur? Quis autem vel eum iure reprehenderit qui in ea voluptate velit esse quam nihil molestiae consequatur, vel illum qui dolorem eum fugiat quo voluptas nulla pariatur?</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}