package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mix)(?P<full_name>(?P<fname>[firstname]{3,})\s\w*?(?P<lname>[lastname]{3,}))`)
var str = `first last
name lastname
fname lname
namef namel
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}