package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sm)^(?|#(.+)|\[name=(.+)])$`)
var str = `[name=anystring]
#anystring`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}