re = /(?m)^([^A-Za-z0-9]+)([0-9_]+)([A-Za-z]+)([0-9_]+)([^A-Za-z0-9]+)$/
str = '*-*
1_1_1
***444asd444***
1_1_1
*-*'
# Print the match result
str.match(re) do |match|
puts match.to_s
end